Costly mistake

November 24, 2018

 

I took the Nikon S3 rangefinder camera out for a spin this morning and loaded it with what I had thought to be a fresh roll of Fujifilm Pro 400H. I was busy having a conversation with a couple of friends as I was loading the camera and totally mistakenly put in a roll of Fujifilm Provia 100 colour positive film instead without realising it due to the similarities of the box design and colour. 

 

I shot an entire roll in Gimme Shelter Service Chop, documenting some custom chopper builds’ progress and of the guys from the shop. It wasn’t until I was at Colourdotcom that I had realised the mistake I made, shooting entirely at iso 400 speed which means everything will turn out underexposed by 2 stops. Hence I need to now push the processing, pay for costlier processing and wait for at least 2 months to see the results. Apparently this is because they will batch process a minimum of 8 rolls at one shot and therefore they’d need to wait for more rolls to come in. 

 

Alternatively, I can opt to cross process the film but end up having lomo-like pictures. I ultimately chose to just wait, cross my fingers and hope that the push processing will work out fine. 

 

I’ll update the blog with frames from this roll once I get the scans back. Anyone else experienced this?

 

 

 

 

Please reload

Featured Posts

Hanging out with The Mighty Motor's Shaik Ridzwan

August 9, 2019

1/9
Please reload

Recent Posts

December 2, 2018

Please reload

Archive
Please reload

Search By Tags
Follow Us
  • Facebook Basic Square
  • Twitter Basic Square
  • Google+ Basic Square

© 2023 by Julian Alejandro. Proudly created with Wix.com